ChargeNet

Incident Report for Mevo

Resolved

This incident has been resolved.
Posted Dec 20, 2025 - 05:11 NZDT

Identified

We’re investigating an issue with ChargeNet. Please use the ChargeNet app to pay for charging and email your receipt to support@mevo.co.nz for reimbursement. We appreciate your understanding.
Posted Dec 19, 2025 - 16:21 NZDT